Sunday, October 2, 2016

MyBatipse (Eclipse plugin) 1.0.23 is released!

Dear MyBatis - Eclipse users,

We have released version 1.0.23 of MyBatipse.

Several enhancements:
  • Rename refactoring : renaming statement, result map and sql fragment will update its references automatically.
  • Propose actual parameter names when 'Store parameter info' option is enabled in Java Compiler setting.
  • Validate result map reference in @ResultMap annotation.
  • Validate select statement reference in @One and @Many annotations.
Please see the GitHub page for the general information.


The minimum required Java/Eclipse versions will be changed as follows in the near future.
  • Java 7
  • Eclipse 4.4 (Luna)